ubuntu-cd

86 weeks have passed since the last update of Turpial’s PPA but we are glad to announce that Turpial is back to Ubuntu.

Efrain Valles has packaged Turpial 3 for Ubuntu Saucy and it’s already available in Turpial stable PPA. To install it you need to add this PPA to your system’s Software Sources and then use apt-get. You can do it in a terminal executing:

sudo add-apt-repository ppa:effie-jayx/turpial
sudo apt-get update && sudo apt-get install turpial

Or if you don’t like PPA’s just download .deb files for libturpial and turpial, install them (manually or double clicking the files) and enjoy!

I’m excited to have Turpial back in Ubuntu and I’ll be doing my best to enhance desktop integration and user experience in this Linux distro. And yes! I used an old-fashioned Ubuntu picture ;)

  • http://www.razzil.com Raza Rahil Hussain

    It will work in Ubuntu 12.04 ?

    • emce

      Yes – you have to follow these instructions:
      apt-add-repository ppa:chris-lea/python-requests –yes
      apt-add-repository ppa:chris-lea/python-simplejson –yes
      apt-get update
      apt-get upgrade
      and install above two packages (libturpial and turpial)

  • tcd

    No funciona nada, “error de autenticación”… Siempre ha tenido ese problema cuando lo intento usar, así que no veo que tan genial dicen que es este programa.

    • Pablo Gabriel Lopez

      Probablemente si solo a ti te sucede es que algo o haces mal o tienes mal en tu maquina, turpial 3 solucionó el problema con las api de twitter

      • Anonymous

        a mi tambien me dice lo mismo, credenciales no validas

    • José J. Valero-Parra

      Estoy en elementary OS. También me da “error de autenticación”. Alguna idea?.

      • Wil Alvarez

        Ese error se presenta cuando hay problemas con las versiones de las dependencias de libturpial. Voy a documentar eso para que puedan resolverlo. Saludos

  • Pingback: Probando Turpial 3 en Ubuntu | El atareao

  • Anonymous

    And it’s already on Ubuntu 14.04 Trusty Tahr!!!
    Weee!!! Lo voy instarlar ya!

  • Pingback: Probando Turpial 3 en Ubuntu #Visitanos http://latertuliadigital.hol.es/ : Tertulia digital

  • Pablo Gabriel Lopez

    ¿Como era el método para ponerlo en español? a ver si ahora que lo instalé desde repos me funciona

  • Pingback: How to Install Turpial 3 via PPA in Ubuntu 13.10 & Linux Mint 16 | UbuntuHandbook

  • Pingback: Turpial 3.0 für Linux: Finale Downloadpakete verfügbar » CocasBlog.de

  • Mangue

    404 not found. Any trouble with the repository ?

  • Jose Pablo

    Luego del cambio de API me quedo en la pantalla de bienvenida en 2 Pcs con Mint 16. La que tiene la leyenda “Hi there! Give me….”
    Pese a que borre toda configuración y lo reinstale quedó allí, no lo puedo resolver.
    Gracias

    • Jose Pablo

      Ya veo en la discusión de desarrolladores que esta reportado el mismo problema, dejo lo capturado en modo debug http://pastebin.com/uF3i15xc

  • B. Ross Ashley

    Hmmmm. Not starting … stuck on startup. Installed by the sudo-add-app-repo method and running on Xubuntu 13.10.

    • Harkinian

      i have the same problem with my own xubuntu, if anybody can help us with that, i give thanks for it, greetings from chile :D

  • Andres Parra

    En Ubuntu 13.10 se me queda arrancando…Con la pantalla de Hi There…Give me a minute. Tengo Ubuntu recien instalado. ¿Sabeis porque puede ser?
    Saludos.

    • Andres Parra

      Vale, he descargador la libreria 1.5.9 y ya me funciona Turpial, pero al darle a preferencias no me carga nada.¿Sabeis porqué puede ser?
      Saludos.

  • frankob

    It doesn’t start on my Ubuntu 13.10 64-bit system… It is stuck on the startup “Hi there!” window.

    Terminal gives me this:

    DEBUG::Using gst as sound system
    /usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:127: RuntimeWarning: PyOS_InputHook is not available for interactive use of PyGTK
    set_interactive(1)
    Fontconfig warning: “/etc/fonts/conf.d/50-user.conf”, line 14: reading configurations from ~/.fonts.conf is deprecated.
    Traceback (most recent call last):
    File “/usr/lib/python2.7/dist-packages/turpial/ui/qt/main.py”, line 592, in after_core_initialized
    width, height = self.core.get_window_size()
    File “/usr/lib/python2.7/dist-packages/turpial/ui/qt/worker.py”, line 509, in get_window_size
    config['Window']['size'] = “320,480″
    KeyError: ‘Window’

  • lenin

    con los .deb ahora tengo el error de i could not reach the internet… alguna idea??

  • Ray Luke

    Doesn’t seem to work in Ubunto12.04. Tried PPA and .deb files. Won’t authenticate but shows as authorised when I look at Apps in Twitter settings.

  • B. Ross Ashley

    In Xubuntu 13.10 with all the kernel updates etc:
    brashley46@rossdesktop2:~$ turpial -d
    DEBUG::Using gst as sound system
    /usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:127: RuntimeWarning: PyOS_InputHook is not available for interactive use of PyGTK
    set_interactive(1)
    DEBUG:AppConfig:Started
    DEBUG:AppConfig:CONFIG_FILE: /home/brashley46/.config/turpial/config
    DEBUG:AppConfig:FILTERS_FILE: /home/brashley46/.config/turpial/filtered
    DEBUG:AppConfig:FRIENDS_FILE: /home/brashley46/.config/turpial/friends
    “sni-qt/12728″ WARN 14:41:22.971 void StatusNotifierItemFactory::connectToSnw() Invalid interface to SNW_SERVICE
    DEBUG:Controller:Starting Turpial 3.0
    Traceback (most recent call last):
    File “/usr/lib/python2.7/dist-packages/turpial/ui/qt/main.py”, line 592, in after_core_initialized
    width, height = self.core.get_window_size()
    File “/usr/lib/python2.7/dist-packages/turpial/ui/qt/worker.py”, line 509, in get_window_size
    config['Window']['size'] = “320,480″
    KeyError: ‘Window’
    /usr/lib/python2.7/dist-packages/turpial/ui/qt/main.py:234: GtkWarning: IA__gtk_widget_get_direction: assertion ‘GTK_IS_WIDGET (widget)’ failed
    self.app.exec_()

  • Mikex321

    I installed via PPA on Linux Mint 16. At run on terminal, i get this, and turpial no go.

    DEBUG::Using gst as sound system
    /usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py:127: RuntimeWarning: PyOS_InputHook is not available for interactive use of PyGTK
    set_interactive(1)
    Fontconfig warning: “/etc/fonts/conf.d/50-user.conf”, line 14: reading configurations from ~/.fonts.conf is deprecated.
    “sni-qt/5559″ WARN 13:05:17.344 void StatusNotifierItemFactory::connectToSnw() Invalid interface to SNW_SERVICE

  • Max

    still not working. stuck on the “give me a minute” splash screen.

  • Moonfire

    You need only to update to the newest libturial lib and all problems in ubuntu are fixed. I tried it and all runs now fine for me.

  • Anibal

    no funciona en ubuntu 14.04 :(

  • Erikson de Leon

    W: Failed to fetch http://ppa.launchpad.net/effie-jayx/turpial/ubuntu/dists/quantal/main/source/Sources 404 Not Found

    W: Failed to fetch http://ppa.launchpad.net/effie-jayx/turpial/ubuntu/dists/quantal/main/binary-amd64/Packages 404 Not Found

    W: Failed to fetch http://ppa.launchpad.net/effie-jayx/turpial/ubuntu/dists/quantal/main/binary-i386/Packages 404 Not Found

    E: Some index files failed to download. They have been ignored, or old ones used instead.